Forum

Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
  1. #16
    Join Date
    September 2013
    Posts
    13
    Quote Originally Posted by Xp9kyc View Post
    elixir v0.10.3
    Distritubive: CentOS release 6.4 (Final)
    Maybe I do something wrong?
    My steps:
    1) I'm installed Erlang (R16B02) by rpm
    2) installed Elixir (i couldn't install it by this command "sudo yum -y install elixir"), so i compiled it from source.
    3) unpacked mambo from tar as in instruction
    4) configured settings.json, my settings is:
    5) Try to compile (mix do deps.get, compile) and here it is (as i describe by top message)
    i see error
    ** (CompileError) /usr/share/mambo/deps/jsex/mix.exs:13: function '__w__'/2 undefined

    Is my steps are correct? Where I could done mistake?
    Try upgrading to elixir master, https://github.com/elixir-lang/elixir, and use this version of mambo https://github.com/mrshankly/mambo/archive/master.zip.

    Btw, you should really put the bot's unique id in the settings file, it's how the bot knows how to ignore what he writes.

    EDIT: Also, you should censor your password when posting the settings file.

  2. #17
    Join Date
    September 2013
    Posts
    13
    Version 0.3.0 is out https://github.com/mrshankly/mambo/releases/tag/v0.3.0

    Make sure you read the readme, a lot of stuff changed since last version.

  3. #18
    Join Date
    March 2013
    Location
    Russian Federation
    Posts
    13
    Quote Originally Posted by mrshankly View Post
    Try upgrading to elixir master, https://github.com/elixir-lang/elixir, and use this version of mambo https://github.com/mrshankly/mambo/archive/master.zip.

    Btw, you should really put the bot's unique id in the settings file, it's how the bot knows how to ignore what he writes.

    EDIT: Also, you should censor your password when posting the settings file.
    Thank you very much for advice!

  4. #19
    Join Date
    May 2014
    Posts
    1
    I'm getting this error when trying to compile.

    [2014/05/20-21:41:44, critical] Error: Cannot parse configuration file!
    [2014/05/20-21:41:44, critical] Terminating Programm!

  5. #20
    Join Date
    September 2014
    Posts
    5

    Teamspeak IRC integration?

    I want to ask if it is possible to connect Teamspeak 3 to IRC using python with the Teamspeak 3 Server query SDK. I'm trying to develop an outside application that connects user channel chat with IRC along with a few commands and silly stuff.

  6. #21
    Join Date
    September 2013
    Posts
    13
    Quote Originally Posted by Khailz View Post
    I want to ask if it is possible to connect Teamspeak 3 to IRC using python with the Teamspeak 3 Server query SDK. I'm trying to develop an outside application that connects user channel chat with IRC along with a few commands and silly stuff.
    Yes, it is. Basically a bot that connects to IRC and teamspeak server query at the same time, every message from IRC/teamspeak the bot sends to teamspeak/IRC.

  7. #22
    Join Date
    November 2014
    Posts
    2
    Hello.
    I've been trying to get your bot working but i can't seem to get it working.
    I'm running on Debian and compiling it first throws an error related to hackney/hackney_lib dependencies. it was something to do with a version check rebar uses that fails even though i have erlang otp 17 installed.
    i've circumvented that and all dependencies build as they should but i bump into a syntax error in lib/mambo/bot.ex before "inlist" at line 215: .

    I figured i'd go with downloading the compiled version from here but that won't run either.
    if i run it in an elixir shell to get the output with command:
    Code:
    elixir mix.exs
    I get the following error:
    Code:
    ** (exit) exited in: GenServer.call(Mix.ProjectStack, {:get_and_update, #Function<12.54516626/1 in Mix.ProjectStack.push/3>}, 30000)
        ** (EXIT) no process
        (elixir) lib/gen_server.ex:356: GenServer.call/3
        lib/mix/project.ex:65: Mix.Project.push/3
        (stdlib) lists.erl:1261: :lists.foldl/3
        (stdlib) erl_eval.erl:657: :erl_eval.do_apply/6
    Any advice on what i'm doing wrong?

    If i'm not providing enough info here to be helpful please tell me what you need and i'll try to supply it.

    Thanks in advance.

  8. #23
    Join Date
    September 2013
    Posts
    13
    Quote Originally Posted by masterwoob View Post
    Hello.
    I've been trying to get your bot working but i can't seem to get it working.
    I'm running on Debian and compiling it first throws an error related to hackney/hackney_lib dependencies. it was something to do with a version check rebar uses that fails even though i have erlang otp 17 installed.
    i've circumvented that and all dependencies build as they should but i bump into a syntax error in lib/mambo/bot.ex before "inlist" at line 215: .

    I figured i'd go with downloading the compiled version from here but that won't run either.
    if i run it in an elixir shell to get the output with command:
    Code:
    elixir mix.exs
    I get the following error:
    Code:
    ** (exit) exited in: GenServer.call(Mix.ProjectStack, {:get_and_update, #Function<12.54516626/1 in Mix.ProjectStack.push/3>}, 30000)
        ** (EXIT) no process
        (elixir) lib/gen_server.ex:356: GenServer.call/3
        lib/mix/project.ex:65: Mix.Project.push/3
        (stdlib) lists.erl:1261: :lists.foldl/3
        (stdlib) erl_eval.erl:657: :erl_eval.do_apply/6
    Any advice on what i'm doing wrong?

    If i'm not providing enough info here to be helpful please tell me what you need and i'll try to supply it.

    Thanks in advance.
    What elixir version are you using? The last supported elixir version is 0.12.4. I no longer use teamspeak and I stopped updating the bot because of that.

  9. #24
    Join Date
    November 2014
    Posts
    2
    I'm using elixir 1.0.0 so that's probably why then. Thanks.

  10. #25
    Join Date
    November 2014
    Posts
    12
    I'd love to see this someone make a clone of this.

  11. #26
    Join Date
    October 2015
    Posts
    27

    help

    [email protected]:/home/bot# iex -S mix
    Erlang/OTP 18 [erts-7.2] [source-e6dd627] [64-bit] [async-threads:10] [hipe] [kernel-poll:false]

    Unchecked dependencies for environment dev:
    * jsx (https://github.com/talentdeficit/jsx.git)
    the dependency is not locked (run "mix deps.get" to generate "mix.lock" file)
    * mimetypes (https://github.com/spawngrid/mimetypes.git)
    the dependency is not locked (run "mix deps.get" to generate "mix.lock" file)
    * hackney (https://github.com/benoitc/hackney.git)
    the dependency is not locked (run "mix deps.get" to generate "mix.lock" file)
    ** (Mix) Can't continue due to errors on dependencies
    [email protected]:/home/bot#


    how can i fix this ?

  12. #27
    Join Date
    January 2016
    Posts
    7

    Updated bot

    Quote Originally Posted by dzinks2009 View Post
    how can i fix this ?
    I have an updated fork of the bot at https://github.com/Inouju/mambo. Try that.

  13. #28
    Join Date
    January 2016
    Posts
    2
    i am using windows
    i installed all the programs and extracted the bot and navigated to the extracted folder using cmd and wrote the command and noting happens i also made settings.json as the example

    HTML Code:
    {
      "name": "mambo",
      "user": "mambo",
      "pass": "*****",
      "host": "localhost",
      "port": 10011,
      "bot_id": "1",
      "admins": ["6", "9"],
      "channels": "all",
      "scripts": [
        {"name": "Sux", "args": []},
        {"name": "Help", "args": []},
        {"name": "Admin", "args": []},
        {"name": "Benis", "args": []},
        {"name": "Utils", "args": []},
        {"name": "Title", "args": []},
        {"name": "Urban", "args": []},
        {"name": "Random", "args": []},
        {"name": "Google", "args": []},
        {"name": "Quotes", "args": []},
        {"name": "Rainbow", "args": []},
        {"name": "Private", "args": []},
        {"name": "Brainfuck", "args": []},
        {"name": "Eightball", "args": []},
        {"name": "Translate", "args": []},
        {"name": "Cannedreplies", "args": []},
        {"name": "Whatthecommit", "args": []},
        {"name": "Gif", "args": []},
        {"name": "Lastfm", "args": "LASTFM API KEY HERE"},
        {"name": "Youtube", "args": "YOUTUBE API KEY HERE"},
        {"name": "Wolframalpha", "args": "WOLFRAMALPHA API KEY HERE"},
        {"name": "Twitter", "args": ["TWITTER CONSUMER KEY","TWITTER CONSUMER SECRET"]}
      ]
    }

  14. #29
    Join Date
    January 2016
    Posts
    7
    Quote Originally Posted by shipstreet View Post
    i am using windows
    i installed all the programs and extracted the bot and navigated to the extracted folder using cmd and wrote the command and noting happens i also made settings.json as the example
    Which version of the bot are you using? You can check this in mix.exs under "version". It is possible that you are using an older version of the bot.

    Also, check out the new thread with the updated bot: http://forum.teamspeak.com/threads/1...or-Teamspeak-3
    Last edited by inouju; January 25th, 2016 at 07:49 PM. Reason: Add link to updated thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: December 23rd, 2009, 02:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •