Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    November 2013
    Posts
    3

    Exclamation Error with MySQL backend

    Since few versions back (3.0.8 maybe), I'm unable to start my server with this error :

    2013-11-09 15:54:31.707876|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.10 (2013-09-27 10:13:58)
    2013-11-09 15:54:31.708131|INFO |ServerLibPriv | | SystemInformation: Linux 3.11.6-hardened-r3 #1 SMP Sat Nov 9 14:34:38 CET 2013 i686 Binary: 32bit
    2013-11-09 15:54:31.713323|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2013-11-09 15:54:31.713444|INFO |DatabaseQuery | | dbPlugin version: 1
    terminate called after throwing an instance of 'std::logic_error'
    what(): basic_string::_S_construct null not valid
    Abandon

    I'm on Gentoo x86.

  2. #2
    Join Date
    June 2008
    Posts
    17,939
    Thread was moved out of bug section.

    Please make sure you did overwrite all files, when your server was updated.
    Also check the permissions from your user.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    November 2013
    Posts
    3
    I did all of these.
    Even tried from scratch : fresh install, fresh database and fresh database user.
    And given the error, I clearly thought it was a bug...
    My bad... But, shouldn't this post belong to server support and not client support?
    Last edited by jackmort; November 12th, 2013 at 01:16 PM.

  4. #4
    Join Date
    November 2013
    Posts
    3
    As I can see no dev cares about this forum and above all, about MySQL backend.
    Forcing the use of such an old client library is just a shame. If you don't want MySQL, just drop its "support".
    Oh and by the way, as I said the thread never belonged to a client support forum. But after one month, oh great moderator, it's still in the wrong forum...
    Anyway, thanks for your non helping, I left my TS server shutdown for good and made the switch to mumble.
    Keep up the bad work.
    --
    A pissed user hoping "support" forum could be of any help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [No Bug] Server Release 3.0.6.1 with MySQL backend ASSERTION
    By tlund in forum Linux / FreeBSD
    Replies: 2
    Last Post: January 3rd, 2013, 01:16 AM
  2. [Rejected] [Pulseaudio-backend] Tagged audio-streams, option for deactivating
    By Master_D in forum Suggestions and Feedback
    Replies: 5
    Last Post: December 5th, 2012, 12:03 AM
  3. Icon problems between Mysql/Sqlite backend
    By jh2000 in forum Server Support
    Replies: 0
    Last Post: May 3rd, 2011, 07:56 PM
  4. TS3 hosting automation backend
    By gurgul in forum Server Support
    Replies: 1
    Last Post: October 2nd, 2010, 05:14 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •