Forum

Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 46 to 60 of 120
  1. #46
    Join Date
    July 2014
    Posts
    3
    Thanks for your replies. I may just have to settle for not hosting a TS server. I asked my provider for help, but their reply was that they only offer the hardware - any software problems are completely up to myself to solve. And I quote, "we depend on your software expertise and our hardware expertise to work together to create a great experience." (OVH.)

    This is what I get when I tried to run chmod 777 /dev/shm as root: chmod: cannot access `/dev/shm': Too many levels of symbolic links

    And this is what I get when I tried to chown the directory to root: chown: cannot dereference `/dev/shm': Too many levels of symbolic links

    Not too big of a deal, the server I'm on possibly is just running quite a few more VPSes than myself and as such there is a stupid amount of symbolic links on these files.

    I will just have to settle, it appears. Thanks anyway.

  2. #47
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    You can still solve it... this is probably simple "symbolic link" error. I notice often that newbies do such a crab by mistake.
    You can simulate it with any symbolic link pointing to itself. Then you can reproduce all the errors you told us.

    e.g.
    Code:
    mkdir /mytest
    cd /mytest
    ln -fs badtest .
    Done... know you have the same mess... a "chmod 777 badtest" or a "chown root:root badtest" or even a "cd badtest" will all result in "error: Too many levels of symbolic links". Just simple as that, you just need to find the broken sym link in the chain... perhaps it is /dev/shm itself... or it is dependable on /dev/shm...

    Just check you sym links, and remove the "bad" one.

  3. #48
    Join Date
    August 2014
    Posts
    2

    error: instance check error

    Hello,

    I'm trying to install a TeamSpeak 3 server on my VPS with Debian 7 64 bits.
    So, I install it, et when I launch it for the first time I got this in logs

    2014-08-06 13:45:39.696425|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-08-06 13:45:39.696799|ERROR |Accounting | | failed to register local accounting service
    2014-08-06 13:45:39.696820|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: instance check error
    I don't have a license.

    Regards
    Last edited by dante696; August 6th, 2014 at 03:23 PM. Reason: merged, we have a search function

  4. #49
    Join Date
    August 2014
    Posts
    1

    Problem trying to install the server on a Unix

    Hi guys, I'm trying to install TS3 server on a Unix, but I'm getting this error:
    Name:  erro2.png
Views: 714
Size:  36.6 KB
    As you can see, when I try to start the script it doesn't generate a token, that what we use to become server admin.

    I tried a lot of things, I don't have root acess so I wanna know if is it the problem.

    Someone has got the same problem before?
    Last edited by dante696; August 19th, 2014 at 11:02 AM. Reason: merged. already answerd on forum and FAQ

  5. #50
    Join Date
    October 2014
    Posts
    1

    Server won't start

    Hey,

    I just purchased at ovh.de a VPS Server (Classic for 2,40€ a month). I chose Debian 7 64bit as OS.
    After the automatic installation of the OS was completed I followed these (ger) steps for creating a ts3 user, dir, etc.

    Now, when I start the server I get following erros in the log files

    Code:
    2014-10-13 17:15:54.089930|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.11 (2014-09-29 15:33:46)
    2014-10-13 17:15:54.090083|INFO    |ServerLibPriv |   | SystemInformation: Linux 2.6.32-042stab092.3 #1 SMP Sun Jul 20 13:27:24 MSK 2014 x86_64 Binary: 64bit
    2014-10-13 17:15:54.091151|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-10-13 17:15:54.091202|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2014-10-13 17:15:54.091670|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2014-10-13 17:15:54.155739|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2014-10-13 17:15:54.157060|ERROR   |Accounting    |   | failed to register local accounting service
    2014-10-13 17:15:54.157109|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    I tried to make these fixes, but there I get erros to :<

    I get "Too many levels of symbolic links" when I try cd /dev/shm/ and mount -t tmpfs tmpfs /dev/shm.

    Could anyone help me?

    greets

    PS: My english isn't the best, sorry for any mistakes :>
    Last edited by dante696; October 16th, 2014 at 12:36 PM. Reason: merged

  6. #51
    Join Date
    September 2012
    Posts
    6,060
    /dev/shm is already a symbolic link to somewhere else, which links back to /dev/shm causing an infinite loop.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  7. #52
    Join Date
    March 2012
    Posts
    4

    failed to register local accounting service

    I did a search for this and found little. One person said that this was due to running the process multiple times, but this is the very first time that this process has been run on this machine.

    Code:
    2014-10-15 15:17:46.664684|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-10-15 15:17:46.664849|INFO    |ServerLibPriv |   | SystemInformation: Linux 2.6.32-042stab084.26 #1 SMP Mon Feb 17 21:00:14 MSK 2014 x86_64 Binary: 64bit
    2014-10-15 15:17:46.665929|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-10-15 15:17:46.665983|INFO    |DatabaseQuery |   | dbPlugin version: 3.6.21
    2014-10-15 15:17:46.666495|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2014-10-15 15:17:46.688839|INFO    |SQL           |   | db_CreateTables() tables created
    2014-10-15 15:17:46.917769|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2014-10-15 15:17:46.918052|ERROR   |Accounting    |   | failed to register local accounting service
    2014-10-15 15:17:46.918105|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    A pid file was created, but there is no process associated with the pid contained.

    Thanks for any help.

  8. #53
    Join Date
    December 2004
    Location
    RF
    Posts
    2,996
    You need shared memory module mounted as /dev/shm.
    If it's mounted in any other place, contact your system administrator and ask, how to correctly make it appear under the /dev/shm.

  9. #54
    Join Date
    March 2012
    Posts
    4
    Thanks. I just did that (I'm the administrator) and it appears to be working now!

  10. #55
    Join Date
    October 2014
    Posts
    2

    Debian 7 - installation not completed

    Hello guys!
    I have as u see the following problem.
    I don't really understand why it stops the installation.
    Its a brand new Debian 7 Wheezy 64bit installation.
    I reinstalled it yesterday after failing to install it the first time.
    I thought it could be a problem with the settings I changed on the machine.
    But at the moment it looks like it wasn't my fault at all.
    I am running a vpserver level 2 at OVH.
    Maybe you can tell me, why the installation stops...


    [email protected]:~/teamspeak3/teamspeak3-server_linux-amd64$ ./ts3server_minimal_runscript.sh
    2014-10-16 10:53:54.054289|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-10-16 10:53:54.054524|INFO |ServerLibPriv | | SystemInformation: Linux 2.6.32-042stab093.5 #1 SMP Wed Sep 10 17:39:49 MSK 2014 x86_64 Binary: 64bit
    2014-10-16 10:53:54.054589|INFO |ServerLibPriv | | Using hardware aes
    2014-10-16 10:53:54.055729|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-10-16 10:53:54.055780|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2014-10-16 10:53:54.056189|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-10-16 10:53:54.130469|INFO |SQL | | db_CreateTables() tables created

    ------------------------------------------------------------------
    I M P O R T A N T
    ------------------------------------------------------------------
    Server Query Admin Account created
    loginname= "serveradmin", password= "lalalalalala"
    ------------------------------------------------------------------

    2014-10-16 10:53:54.372263|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-10-16 10:53:54.373434|ERROR |Accounting | | failed to register local accounting service
    2014-10-16 10:53:54.373481|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: instance check error
    Last edited by dante696; October 16th, 2014 at 12:28 PM. Reason: mereged

  11. #56
    Join Date
    June 2008
    Posts
    17,708
    We have serveral answered threads and we also have a FAQ for this

    https://support.teamspeakusa.com/ind...-do-i-fix-this
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #57
    Join Date
    October 2014
    Posts
    2
    Quote Originally Posted by dante696 View Post
    We have serveral answered threads and we also have a FAQ for this

    https://support.teamspeakusa.com/ind...-do-i-fix-this
    I wouldn't ask for it if I got the solution that easy.
    I already tried to mount it but no way debian restricts of letting me mount it.
    Trying to actives it in stab wasnt possible because it was already active.

  13. #58
    Join Date
    November 2014
    Location
    City
    Posts
    1
    hmmm i have problem when The server is running on stable Debian x64 with mariadb I see error plisss help me

    [email protected]:~/teamspeak3-server_linux-amd64$ ./ts3server_minimal_runscr ipt.sh start inifile=ts3server.ini
    2014-11-19 15:38:57.543590|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0. 11.1 (2014-10-15 07:06:31)
    2014-11-19 15:38:57.543806|INFO |ServerLibPriv | | SystemInformation: Linu x 2.6.32-042stab093.5 #1 SMP Wed Sep 10 17:39:49 MSK 2014 x86_64 Binary: 64bit
    2014-11-19 15:38:57.543879|INFO |ServerLibPriv | | Using hardware aes
    2014-11-19 15:38:57.546984|INFO |DatabaseQuery | | dbPlugin name: Maria DB plugin, (c)TeamSpeak Systems GmbH
    2014-11-19 15:38:57.547057|INFO |DatabaseQuery | | dbPlugin version: 1
    2014-11-19 15:39:00.778193|INFO |SQL | | db_CreateTables() table

    ------------------------------------------------------------------
    I M P O R T A N T
    ------------------------------------------------------------------
    Server Query Admin Account created
    loginname= "serveradmin", password= "sdfdsf"
    ------------------------------------------------------------------

    2014-11-19 15:39:05.864287|WARNING |Accounting | | Unable to find valid li
    2014-11-19 15:39:05.865746|ERROR |Accounting | | failed to register loca
    2014-11-19 15:39:05.865799|ERROR |ServerLibPriv | | Server() error while st
    [email protected]:~/teamspeak3-server_linux-amd64$
    Last edited by dante696; November 19th, 2014 at 07:30 PM. Reason: merged has nothing to do with server 3.0.11.1

  14. #59
    Join Date
    December 2004
    Location
    RF
    Posts
    2,996
    Same answer. Your server is unable to connect to accounting service.
    Read documentation, fix your internet connection.

  15. #60
    Join Date
    December 2014
    Posts
    3

    Reinstalling (Clean?)

    I first installed it on my linux server in the wrong folder..
    So I just deleted the files to reinstall it in the correct folder but now I dont recieve the token key.
    And I tried a million times reinstalling it both in the wrong folder and others. Then I realized that I probably need a clean uninstall of all the files. Im not the best with linux so ye. I basically used these commands to install it.
    useradd -d /home/teamspeak teamspeak
    su teamspeak
    cd /home/teamspeak/
    wget http://teamspeak.gameserver.gamed.de/...
    tar -xvf teamspeak3-server_linux-amd64-3.0.1.tar.­gz
    tar -xvf teamspeak3-server_linux-x86-3.0.1.tar.gz
    cd teamspeak3-server_linux-x86
    ./ts3server_minimal_runscript.sh (First use Script)(Only use once)
    Pretty much. And ye now I cant install it again cuz I dont recieve a token key when I reinstall it.
    So exactly what do I do to remove this? I have installed it a million times in /var/lib/(teamspeak) - Removed Teamspeak folder and a million times in /home/(teamspeak) removed that folder too.. So how do I remove all the hidden features so I can make a clean new install??

    Basically used different versions too and not the exact one listed above. Just basically used those commands..
    Last edited by dante696; December 8th, 2014 at 10:31 AM. Reason: merged

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 146
    Last Post: November 24th, 2018, 11:20 AM
  2. Replies: 3
    Last Post: April 27th, 2018, 09:41 AM
  3. Failed to register accounting service
    By Supermaf in forum Windows
    Replies: 2
    Last Post: January 29th, 2015, 09:11 AM
  4. Replies: 2
    Last Post: August 20th, 2010, 02:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •