Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9
  1. #1
    Join Date
    August 2013
    Posts
    8

    Error starting server on CentOS

    Hello, I have followed instructions on how to install the teamspeak 3 server on my linux VPS, but when I execute the start script, I am only presented with the ServerQuery login info; no token.

    These are the errors:

    Code:
    2013-12-09 21:21:23.479875|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2013-12-09 21:21:23.480571|ERROR   |Accounting    |   | failed to register local accounting service
    2013-12-09 21:21:23.480597|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    Isn't it free to host a single Teamspeak server? Why would I need a valid license key?

  2. #2
    Join Date
    August 2013
    Posts
    8
    Quote Originally Posted by mntwins7 View Post
    Hello, I have followed instructions on how to install the teamspeak 3 server on my linux VPS, but when I execute the start script, I am only presented with the ServerQuery login info; no token.

    These are the errors:

    Code:
    2013-12-09 21:21:23.479875|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2013-12-09 21:21:23.480571|ERROR   |Accounting    |   | failed to register local accounting service
    2013-12-09 21:21:23.480597|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    Isn't it free to host a single Teamspeak server? Why would I need a valid license key?
    Found the error in the Knowledgebase

    https://support.teamspeakusa.com/ind...-do-i-fix-this

  3. #3
    Join Date
    August 2013
    Posts
    8

    CentOS Server won't run?

    Hello, I have followed this guide: http://forum.teamspeak.com/showthrea...-Server-CentOS

    I've tried multiple times to get the server running but to no avail.

    I put the NPL liscence in my TS3 Server root and ran the server, and all I get is:

    Code:
    ------------------------------------------------------------------
                          I M P O R T A N T
    ------------------------------------------------------------------
                   Server Query Admin Account created
             loginname= "serveradmin", password= "sVpRjmMQ"
    ------------------------------------------------------------------
    I can't connect to the IP either.

    How do I fix this?

  4. #4
    Join Date
    December 2013
    Location
    Australia
    Posts
    7
    Are you trying to telnet to your server (on port 10011) for query access, login via the teamspeak client or have you tried both?

    Have you checked the log files in the log directory to see if any helpful errors or warnings might be given.

    Does your centos server have a firewall running such as (iptables) running that could be preventing traffic to your teamspeak ports?

    Can your client computer connect to another server (ie. is the firewall at your house allowing traffic to the server)?

  5. #5
    Join Date
    August 2013
    Posts
    8
    Quote Originally Posted by Ryan.Smith View Post
    Are you trying to telnet to your server (on port 10011) for query access, login via the teamspeak client or have you tried both?

    Have you checked the log files in the log directory to see if any helpful errors or warnings might be given.

    Does your centos server have a firewall running such as (iptables) running that could be preventing traffic to your teamspeak ports?

    Can your client computer connect to another server (ie. is the firewall at your house allowing traffic to the server)?
    Haven't tried to telnet, and nothing in the logs. Iptables doesn't even work, and no firewall is blocking

  6. #6
    Join Date
    August 2013
    Posts
    8
    LOGS FILE-The license file is indeed in my install dir

    2013-12-11 02:08:38.861496|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.6.1 (2012-06-29 07:59:05)
    2013-12-11 02:08:38.861696|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2013-12-11 02:08:38.861719|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2013-12-11 02:08:38.861880|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2013-12-11 02:08:38.887596|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2013-12-11 02:08:38.888289|ERROR |Accounting | | failed to register local accounting service
    2013-12-11 02:08:38.888310|ERROR |ServerLibPriv | | Server() error while starting servermanager, error: instance check error

  7. #7
    Join Date
    June 2008
    Posts
    18,513
    Why do you open a second thread about the same problem?

    Threads merged
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    August 2013
    Posts
    8
    Quote Originally Posted by dante696 View Post
    Why do you open a second thread about the same problem?

    Threads merged
    Oops. Sorry

  9. #9
    Join Date
    April 2009
    Location
    Germany
    Posts
    173
    Hi MNtwins7

    Is the Error Solved ?
    Or still there ?

    If it still there look if /dev/shm is mounted.

    Regards Sargnagel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem starting ts3 server on CentOS with NPL
    By IrystonVinicius in forum Server Support
    Replies: 8
    Last Post: May 27th, 2013, 05:15 AM
  2. [Resolved] Error when installing teamspeak on CentOS 5 VPS Server
    By Lone.Renegade in forum Linux / FreeBSD
    Replies: 2
    Last Post: April 11th, 2013, 05:18 PM
  3. [Resolved] Error starting server on vps running centos 5
    By Samkitz in forum Linux / FreeBSD
    Replies: 1
    Last Post: July 24th, 2012, 10:51 PM
  4. TS3 -> Error on running server on CentOS
    By KevinsL in forum Linux
    Replies: 8
    Last Post: June 28th, 2011, 07:30 PM
  5. Error installing TS3 on CentOS Server
    By umarsa in forum Server Support
    Replies: 2
    Last Post: July 22nd, 2010, 07:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •