Forum

Results 1 to 9 of 9
  1. #1
    Join Date
    December 2013
    Posts
    10

    Stream mic to speakers

    Is there a way to make my mic sound on the speakers?

    I am using Overwolf to captures my games, but it can record the speakers or the microphone. It can't do both at once. I'd like my voice to be echoed on my speakers (using headphone, of course, to avoid feedback).

    I know Windows 7 allows you to echo your microphone on speakers, but this isn't good, as it is "always on". I only want the microphone to sound on the speakers when I hit the push-to-tank button.

    How can this be done?

  2. #2
    Join Date
    December 2013
    Posts
    24
    Hey there!

    To record both the game sounds and your microphone all you need to do is:

    1. Right click on your speaker icon in the system tray, click on Recording devices.
    2. Go to your active microphone and click on Properties.
    3. Go to the "Listen" tab and check "Listen to this device".

    Then in your Overwolf, go to the video settings and check that the sound that is being recorded is the system sound and you should have both!

    Also, to use the headphones use this fix here: http://forums.overwolf.com/viewtopic...start=15#p8495

  3. #3
    Join Date
    December 2013
    Posts
    10
    OWRaif, Thanks for your response.

    If i click the "Listen to this device" check-box, Windows streams the microphone to the speakers continuously, regardless of me using the push-to-talk key. That will result in a video that has all my breathing, coughs ans sneezes. I only want the microphone to be stream to the speaker if I hit the PTT button.

    (I have no issues with speakers/headphones)

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Use "local test mode" in TS3: Go to Settings, Capture, set a hot key and then use the test mode.

  5. #5
    Join Date
    December 2013
    Posts
    10
    I can't use "test mode", as it is in the settings window and it goes away when I close the settings window.

    Anyway, It's a hack. I'm looking for an actual solution, either by a Teamspeak setting/pluggin/addon that can stream the voice only when I push to talk, or by an update/tweak for/to overwolf that will record the speakers [B]and[B] the input from the microphone.

  6. #6
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Quote Originally Posted by SummerBulb View Post
    I can't use "test mode", as it is in the settings window and it goes away when I close the settings window.
    Why? Do? You? Close? It? Then?

  7. #7
    Join Date
    December 2013
    Posts
    10
    Quote Originally Posted by numma_cway View Post
    Why? Do? You? Close? It? Then?


    Well, It seemed to me that I won't be able to interact with the main TS window if i don't close the settings window. WRONG!

    So, two questions remain:
    1. Since I'm using the Overwolf overlay application, will it stay on top? Can't check right now, but I guess the answer is: no.
    2. How long does the "test mode" stay active? Does it stay active until clicked-off or does it time-out?

    If 1=no and 2=no-timeout, then this is the best workaround I know of up to know.

    Thanks!

    EDIT:

    Just checked. Using Overwolf, if you don't close the settings menu, it stays popped up on the screen (hiding the game...). If you try to move it out of sight, Overwolf "helps" you and puts it back where you can see it :/
    This happen whether you open it using the Overwolf shortcuts or directly from the desktop (after Alt-Tab).
    Also, when I use the "test mode" I get terrible echo. Is this just s test-mode side effect or is this really what everyone else is hearing?
    Last edited by SummerBulb; December 26th, 2013 at 05:05 AM. Reason: Added information

  8. #8
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Quote Originally Posted by SummerBulb View Post
    Just checked. Using Overwolf, if you don't close the settings menu, it stays popped up on the screen (hiding the game...). If you try to move it out of sight, Overwolf "helps" you and puts it back where you can see it :/
    Win+D

    Quote Originally Posted by SummerBulb View Post
    This happen whether you open it using the Overwolf shortcuts or directly from the desktop (after Alt-Tab).
    “If I enable the echo, I get an echo.” You must be a genius to have found that. Did you find that alone or did you have help? I’ll recommend you for the Ig Noble Prize this year.

    Quote Originally Posted by SummerBulb View Post
    Also, when I use the "test mode" I get terrible echo. Is this just s test-mode side effect or is this really what everyone else is hearing?
    Why don’t you simply try before asking? Noone in this world has your problem, so everyone would just have to test that himself, just of you being too lazy to just try.

  9. #9
    Join Date
    December 2013
    Posts
    10
    numma_cway, Thanks for your help.

    It's unclear why your tone has changed to be offensive.

    Anyway:

    Win+D - I'll check that. Although, it might fail if I try to switch channels. The window might pop up again. I'll have to check it.

    Echo - I was probably not clear enough. I'm using a headset. There is no feedback from the speakers to the microphone. What I'm experiencing is that if I say a word it is heard about three times, fading.

    As stated in the previous posts, I have tried several solutions and will keep trying until I get a something that satisfies my needs.

    Thanks for your support.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: February 12th, 2015, 09:59 PM
  2. Welcome-Stream?
    By SorcFun in forum Client Plugins / Lua Scripts
    Replies: 2
    Last Post: November 24th, 2010, 04:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •