Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    January 2014

    (Urgent) Microphone issues

    Hey thanks for reading,

    I recently bought a Medusa NX USB 5.1 Surround Headset (SpeedLink) which I took out of the box, plugged it in to the USB hole, I went into Sound, under 'Recording' I see 'Microphone' and green lines moving up and down which means it's working.

    However when I go into TeamSpeak it doesn't work, I can hear people but they can't hear me. At best they hear sound for half a second and then it disappears.

    I went into Options > Capture and set my capture Device as 'LeMicrophone' (I renamed it that) and it should work with Push to talk but doesn't so I tried Continuous Transmission and Voice Activation Detection and still nothing.

    I went in the program called 'Sound Recorder' and I recorded myself and I came out perfectly and could hear myself. I then went onto an online microphone testing program and it works there as well. Went to Skype and green bars move smoothly as I talk so I guess it works.

    I tried Ventrilo and it doesn't work there either.

    So for some reason TS and Vent won't work with my mic.

    Anyone have any ideas?

  2. #2
    Join Date
    September 2013
    Did u get any driver with the microphone? Your problem must be on capture device, the one u set is probably aint right......and try putting direct sound on capture mode.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Urgent Server Issues - No ticket reponse
    By Alderman in forum Server Support
    Replies: 3
    Last Post: June 25th, 2013, 04:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts