Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 6 of 6
  1. #1
    Join Date
    January 2014
    Posts
    4

    Trouble setting it up in CentOS

    I keep getting errors about permissions denied, etc.. I been following a lot of tutorials on how to set it up but they don't really explain how to change the permissions.

    I will post the steps that I'm following in order:

    1. login to root
    2. adduser TS3
    3. passwd TS3
    4. Change pass
    5. Here I manually upload the TS3 files using FTP
    6. chown -R TS3:TS3 /home/TS3
    7. su TS3
    8. ./ts3server_startscript.sh start

    After that I get permission denied.

    Most of the tutorials I've been following include the "chown -R TS3:TS3 /home/TS3" step. Others don't, so I'm confused.

  2. #2
    Join Date
    December 2009
    Location
    New Jersey USA
    Posts
    77
    Make sure the ts3server_startscript.sh has a permission of 755

  3. #3
    Join Date
    April 2009
    Location
    Germany
    Posts
    173
    Hi Malibuz0r,

    1. login to root
    2. adduser TS3
    3. passwd TS3
    4. Change pass
    4.1 Login as TS3
    5.1 wget the Server and extrackt it.
    8. As TS3 ./ts3server_startscript.sh start

    Taadaaa

    Regards Sargnagel

  4. #4
    Join Date
    August 2013
    Location
    Germany
    Posts
    530
    Please try
    chmod +x ts3server_startscript.sh

  5. #5
    Join Date
    January 2014
    Posts
    4
    Quote Originally Posted by BaDaSS View Post
    Make sure the ts3server_startscript.sh has a permission of 755
    Quote Originally Posted by Matthias B View Post
    Please try
    chmod +x ts3server_startscript.sh
    Done, but now I get:

    Code:
    [[email protected] teamspeak3-server_linux-amd64]$ ./ts3server_startscript.sh start
    Starting the TeamSpeak 3 server
    ./ts3server_startscript.sh: line 68: ts3server.pid: Permission denied
    TeamSpeak 3 server started, for details please view the log file
    [[email protected] teamspeak3-server_linux-amd64]$ 2014-01-29 18:05:58.492173|CRITICAL|ServerLibPriv |   | Server() DatabaseError out of memory
    It works perfectly fine if I use root though, but not sure if that's safe to do.
    --

    Edit: Scratch all that. Rebooted my system, su TS3 and it started perfectly fine. Thanks again!

  6. #6
    Join Date
    December 2009
    Location
    New Jersey USA
    Posts
    77
    Glad it worked out, your welcome!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Issues setting up server on CentOS 7 VPS
    By mangusbrother in forum Linux / FreeBSD
    Replies: 4
    Last Post: November 16th, 2014, 05:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •