Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    February 2010
    Location
    Bedford, TX
    Posts
    22

    Angry TS3 CentOS - StartScript does not stay running (and other problems)

    Hello all,

    So I've been working with TeamSpeak for a while on Linux now and it's been OK... But, recently, we're running into problems. I honestly think these problems have more to do with the physical server or the CentOS install (or the restrictions on the account running TS), but the server owner doesn't want to change anything. So if my results from posting this thread indicate a non-TS issue, I will be moving providers or issuing a sever tongue-punching to the owner.

    So, as I said, things were working fine... For the most part. I've had weird issues with getting TS to remain running after I close my SSH connection, but it seemed to "just work" after a few tries. Now the server will not stay running at all after I close the SSH connect after launching "./ts3server_startscript.sh start". There is nothing in the log files indicating any failure at all (they just seem to stop) and immediately after I close the SSH connection to the shell, all aspects of TeamSpeak connected to this server quit working (I can try typing a message to someone and nothing comes up, for example) then the client gets disconnected a short few second later. I will log back into the server and run the above command again and it will report "the server seems to have died" and proceeds to start a new instance. This particular one is driving me crazy because I cannot remain connected to the shell 24/7.

    I'm assuming it has something to do with the permissions on the user running TS, but I'm not really sure where to look since it was working fine a short month ago.

    On top of that, I recently tried to add devMX's TeamSpeak 3 Webviewer to the web host and I successfully got everything configured but the second I tried to view the "webviewer", TeamSpeak crashed with an "Failure during pthread_create, error = EAGAIN" error. Around the same time, I started seeing tons of these errors in the log files "TS3ANetwork::Send failed error: 1".

    So I completely removed all instances of Webviewer and tried to thin out everything as much as possible, but now I'm faced with the server's inability to run without me being connected to the shell. I think if I can get through this particular problem I will be able to focus on some of the webviewer issues, so I'm asking for your help with that issue in particular.

    I have ran the ULIMIT -a command and see that the max user processes is only 35. This has been the same for over a year now and TS has been functioning fine - but if you guys tell me that is the problem, then I will relay that to the server owner in hopes that he will increase it (to 50 I think is the minimum recommended by TS, but I will wait to hear back from you).

    Please let me know what you think or if you need any further information to make a determination.
    Thank you for all of your help!
    Sincerely,
    -[AK907]GvnrRickPerry


    EDIT: Linux Version:
    CentOS 6.5
    Last edited by GvnrRickPerry; February 7th, 2014 at 06:53 PM. Reason: add CentOS Kernel version

  2. #2
    Join Date
    April 2009
    Location
    Germany
    Posts
    173
    Hi GvnrRickPerry,

    at Cent OS i had an failure like yours.
    The problem was thet /dev/shm was not Mounted and not aviable in the /dev.

    I think i made mkdir /dev/shm and addet it to the /et/fstab with default settings
    Please check if /dev/shm is Mounted

    Im sorry i had an Link for this Problem but not Bookmared it try Googel.
    I will search for it and Post it when found.

    in /etc/fstab you have to find :
    tmpfs /dev/shm tmpfs defaults 0 0

    Here the Link i found this :
    https://bugzilla.openvz.org/show_bug.cgi?id=2267


    What tells the Server Log ?

    Regards Sargnagel.

    Updated Link

  3. #3
    Join Date
    February 2014
    Posts
    8
    I've had the same issue when starting the teamspeak server from an ssh session. In my case the reason was that the teamspeak server does not completely disconnect from the ssh session, and any remaining processes in the ssh session are terminated when you disconnect.

    prefixing the start script with nohup is insufficient because of the way the teamspeak server forks, but prefixing with setsid should work.

  4. #4
    Join Date
    February 2010
    Location
    Bedford, TX
    Posts
    22
    Ok, I think I got the server running for good now... I'm not sure what was done, but the server owner had to change something with the account.

    Now I can report that TeamSpeak is crashing whenever I try to access the TS3 WebViewer plugin, or attempt to use it in any way. This is the error TeamSpeak is reporting:

    Code:
    2014-02-15 19:22:15.084136|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:22:15.084469|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:32:11.286586|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:32:11.286919|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:32:13.100807|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:32:13.101095|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:32:15.011354|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:32:15.011649|ERROR   |              |   | TS3ANetwork::Send failed error: 1
    2014-02-15 19:39:07.085603|CRITICAL|              |   | Failure during pthread_create, error = EAGAIN
    There was several seconds between the time the server crashed and the time the TeamSpeak client was disconnected. I really don't know where to go with this one, so any thoughts would be greatly appreciated!
    Thanks,
    -Gvnr

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CentOS: Server running but unable to connect
    By Glotty in forum Server Support
    Replies: 14
    Last Post: October 13th, 2013, 07:11 PM
  2. [Resolved] Error starting server on vps running centos 5
    By Samkitz in forum Linux / FreeBSD
    Replies: 1
    Last Post: July 24th, 2012, 11:51 PM
  3. TS3 -> Error on running server on CentOS
    By KevinsL in forum Linux
    Replies: 8
    Last Post: June 28th, 2011, 08:30 PM
  4. Problem running TS3 on Centos vps
    By some_user in forum Linux / FreeBSD
    Replies: 22
    Last Post: January 26th, 2010, 04:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •