Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    March 2014
    Posts
    1

    Lua Plugin dont work

    I have the lastest version of TS3 client, and I need activate the Lua Plugin, to make work the addon Mass_EH_Tools_V1.1_Release (I have extracted the files on the lua plugin folder), on the window of Settings -> Plugins, but when i try to mark the Lua, appears one box with the msge "Warning, Failed to initialize plugin".

    And the Lua plugin, on the window of plugins, appears with red text.

    PD: I have tried mark the lua with and without the addon, and have installed and removed the program of TS3 several times, sometimes deleting the configuration, and nothing work, always the same msg, and i cant activate that plugin.
    And I have deleted the plugin folder from my pc, and replaced for the folder of plugins of my friend too, and nothing work.

    Here the details:

    Name: Lua Plugin

    Version: 1.0

    Author: TeamSpeak Systems GmbH

    Description: Lua script support for the TeamSpeak 3 client.

    Keyword: lua

    API Version: 20

    Required: 20

  2. #2
    Join Date
    June 2008
    Posts
    18,506
    We can't reproduce that issue with and without that plugin.
    Tested on 64 bit and 32 bit client 3.0.14.


    Please do not start 4 threads about the same topic!
    Last edited by dante696; March 17th, 2014 at 10:29 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    September 2012
    Posts
    6,079
    Make sure you have the following files in plugins/lua_plugin and that you can read those:
    • ts3autoload.lua
    • ts3defs.lua
    • ts3errors.lua
    • ts3events.lua
    • ts3init.lua
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  4. #4
    Join Date
    March 2016
    Posts
    1
    Quote Originally Posted by Chris View Post
    Make sure you have the following files in plugins/lua_plugin and that you can read those:
    • ts3autoload.lua
    • ts3defs.lua
    • ts3errors.lua
    • ts3events.lua
    • ts3init.lua
    I know this post is super old but I'm having the same problem, those files aren't in my lua plugin. Any chance you can link me to where i could find a dl to the files?

  5. #5
    Join Date
    June 2008
    Posts
    18,506
    These are installed automatically with every update or with the client installer itself.
    If you do not have them in your plugins\lua_plugin folder, then you did delete them or the updater had no permissions to write files.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •