Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 6 of 6
  1. #1
    Join Date
    March 2014
    Posts
    3

    Solved Server only works under root

    On my VPS i have 2 users, root and ts3. If I run ./ts3server_startscript.sh start as root, it starts, and works fine, I can connect to it. If I run that command as ts3, it SAYS it starts up fine, but I can't connect. Does the ts3 user need any certain permissions so I can be able to connect as I don't want to run my server as root.

  2. #2
    Join Date
    September 2012
    Posts
    6,079
    Check the logs of the TS3 Server when you run it as regular user, it should tell you what's going wrong. If you can't understand the logs post them.
    The server works fine as a regular user, as long as all the files and folders belonging to TeamSpeak are read & writable by the user that is running the TeamSpeak server.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    March 2014
    Posts
    3
    I get the following log after running as ts3

    Code:
    2014-03-27 12:21:50.614343|INFO    |ServerLibPriv |   | Server Version: 3.0.0-rc1 [Build: 14468], Linux
    2014-03-27 12:21:50.614556|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-03-27 12:21:50.614597|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2014-03-27 12:21:50.614856|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2014-03-27 12:21:50.643819|INFO    |SQL           |   | pruning old database log entries where timestamp is older than 90 days
    2014-03-27 12:21:50.658210|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2014-03-27 12:21:50.658455|ERROR   |Accounting    |   | failed to register local accounting service
    2014-03-27 12:21:50.658499|ERROR   |ServerLibPriv |   | Server() error while starting servermanager, error: instance check error
    What do the warnings and errors mean?

  4. #4
    Join Date
    September 2012
    Posts
    6,079
    That is answered in our FAQ.
    Either /dev/shm is not available or the ts3 user has no permissions to access it.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  5. #5
    Join Date
    March 2014
    Posts
    3
    Thanks works like a treat now!

  6. #6
    Join Date
    July 2006
    Posts
    1,600
    Quote Originally Posted by tomharto View Post
    Code:
    2014-03-27 12:21:50.614343|INFO    |ServerLibPriv |   | Server Version: 3.0.0-rc1 [Build: 14468], Linux
    Why are you using an ancient server version?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: March 9th, 2015, 10:58 PM
  2. Replies: 0
    Last Post: May 4th, 2011, 02:22 AM
  3. [Solved] does an ts3 server 20 slots works fine on this v-root?
    By pennywise1911 in forum Linux / FreeBSD
    Replies: 3
    Last Post: June 24th, 2010, 03:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •