Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    March 2014
    Posts
    4

    TS3ANetwork::Connect failed error: 22

    I successfuly set up the server on CentOS 6.5 linux, however when I try connecting to it with the TS3 Client it says "Failed to Connect to Server" on the client.

    I checked my log file and this is what I get

    Code:
    2014-03-30 17:20:25.132339|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.10.3 (2014-01-01 16:28:39)
    2014-03-30 17:20:25.132735|INFO    |ServerLibPriv |   | SystemInformation: Linux 2.6.32-431.11.2.el6.x86_64 #1 SMP Tue Mar 25 19:59:55 UTC 2014 x86_64 Binary: 64bit
    2014-03-30 17:20:25.135198|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-03-30 17:20:25.135299|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
    2014-03-30 17:20:25.135991|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
    2014-03-30 17:20:25.157294|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
    2014-03-30 17:20:25.729970|INFO    |              |   | Puzzle precompute time: 564
    2014-03-30 17:20:25.734410|INFO    |FileManager   |   | listening on 127.0.0.1:30033
    2014-03-30 17:20:25.824775|INFO    |Query         |   | listening on 127.0.0.1:10011
    2014-03-30 17:25:25.826348|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.827154|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.827794|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.828271|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.828897|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.842229|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.842855|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
    2014-03-30 17:25:25.881554|ERROR   |              |   | Could not open/bind UDP connection on 127.0.0.1 for weblist. Using default

    ts3server.ini
    Code:
    achine_id=
    default_voice_port=9987
    # 9987 UDP Port
    voice_ip=127.0.0.1
    licensepath=
    filetransfer_port=30033
    # 30033 TCP Port
    filetransfer_ip=127.0.0.1
    query_port=10011
    # 10011 TCP Port
    query_ip=127.0.0.1
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    I have not opened the port for weblist as I am not using whatever web based thing TS3 uses, that should be fine right?

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    Using 127.0.0.1 fore voice here is a bad idea.
    Only the user from that machine is able to connect.
    Nobody from outside can.

    And it seems that this ip doesn't exist.
    Last edited by dante696; March 31st, 2014 at 10:15 AM. Reason: sry for misunderstanding @ANR Daemon
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    March 2014
    Posts
    4
    Well I originally put my external IP instead and I would get an error saying "failed to bind port to address", when I looked up that error I read that I am supposed to put the loopback address in there instead. What should I put as the address instead, my internal IP?

  4. #4
    Join Date
    August 2013
    Location
    Germany
    Posts
    530
    Just use 0.0.0.0, that should solve the problem.

    You might want to keep this setting for Server Query connections though, as it will only allow internal connections to the server query interface. There are a couple of people who do this to improve the security.

    Please also check out the server_quickstart.txt in the doc subdirectory, there is a section on those "parameters".

  5. #5
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    If all else fails, you'd probably need to check for existing service (not necessarily TS3) running on the same addressort.
    That's the only other explanation I can think about for your troubles.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] TS3ANetwork::Connect failed error: 111
    By djdiper in forum Server Support
    Replies: 68
    Last Post: August 22nd, 2018, 05:07 AM
  2. TS3ANetwork::Connect failed error: 110
    By gpcore in forum Server Support
    Replies: 36
    Last Post: March 9th, 2018, 01:55 AM
  3. TS3ANetwork::Connect failed error: 60
    By Kenneth M in forum macOS
    Replies: 2
    Last Post: November 12th, 2012, 08:05 PM
  4. TS3ANetwork::Connect failed error: 101 ??
    By Mikebazz in forum Linux / FreeBSD
    Replies: 0
    Last Post: April 15th, 2012, 03:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •