Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 11 of 11
  1. #1
    Join Date
    February 2011
    Location
    Russia
    Posts
    23

    Question Qt platform plugin "xcb"

    Hello.

    When try to start client:
    Code:
    # ./ts3client_runscript.sh 
    This application failed to start because it could not find or load the Qt platform plugin "xcb".
    
    Available platform plugins are: xcb.
    
    Reinstalling the application may fix this problem.
    ./ts3client_runscript.sh: line 17:  1771 Aborted                 ./ts3client_linux_x86 [email protected]
    Code:
    # ~/ts14# ldd ts3client_linux_x86
            linux-gate.so.1 =>  (0xb7747000)
            libQt5Core.so.5 => /lib/libQt5Core.so.5 (0xb7218000)
            libQt5Gui.so.5 => /lib/libQt5Gui.so.5 (0xb6e52000)
            libQt5Widgets.so.5 => /lib/libQt5Widgets.so.5 (0xb6845000)
            libQt5Network.so.5 => /lib/libQt5Network.so.5 (0xb6705000)
            libQt5Sql.so.5 => /lib/libQt5Sql.so.5 (0xb66c8000)
            libresolv.so.2 => /lib/libresolv.so.2 (0xb66b4000)
            libz.so.1 => /usr/lib/libz.so.1 (0xb66a0000)
            librt.so.1 => /lib/librt.so.1 (0xb6697000)
            libdl.so.2 => /lib/libdl.so.2 (0xb6692000)
            libquazip.so.1 => /lib/libquazip.so.1 (0xb6660000)
            libpthread.so.0 => /lib/libpthread.so.0 (0xb6647000)
            libm.so.6 => /lib/libm.so.6 (0xb6621000)
            libc.so.6 => /lib/libc.so.6 (0xb64dc000)
            /lib/ld-linux.so.2 (0xb7748000)
            libstdc++.so.6 => /root/ts3c/libstdc++.so.6 (0xb63ea000)
            libgcc_s.so.1 => /root/ts3c/libgcc_s.so.1 (0xb63cb000)
    Code:
    # locate libxcb.so.1
    /usr/lib/libxcb.so.1
    /usr/lib/libxcb.so.1.1.0
    /usr/lib/debug/usr/lib/libxcb.so.1.1.0

    Can anyone help me?

    # Debian 6.0.8
    Last edited by tabyret; April 7th, 2014 at 11:58 AM.

  2. #2
    Join Date
    April 2014
    Posts
    2
    Surprising no one else has run into this issue on a Linux based system. I've run into the exact same problem and re-installing isn't the solution.

  3. #3
    Join Date
    June 2008
    Posts
    18,513
    I am sure this is caused from missing QT5 libarys on Debian 6 (maybe 7 too).
    troyce what is your OS?

    Maybe we can do something here or we can't.
    Will test that next week.

    Please use client 3.0.13.1 as a workaround.
    http://dl.4players.de/ts/releases/3.0.13.1/
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    April 2014
    Posts
    2
    Ubuntu 10.04 LTS - the Lucid Lynx

    Its a work computer so updating the OS isn't a option at this time .

  5. #5
    Join Date
    June 2008
    Posts
    18,513
    About Debian:
    I just installed Debian 6.0.9 and the client did start without any problems.
    Name:  Debian 6.png
Views: 13492
Size:  233.5 KB
    Please update to the latest version of Debian 6.


    Quote Originally Posted by troyce View Post
    Ubuntu 10.04 LTS - the Lucid Lynx
    Its a work computer so updating the OS isn't a option at this time .
    But this OS has reached it's end of support "May 2013"
    https://wiki.ubuntu.com/Releases
    Please update your OS or stay with client 3.0.13


    - You could try
    1. to run following commands in tsclient folder
    Code:
    export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"
    ldd platforms/libqxcb.so
    1.1 Search for missing libarys and add them.


    2. to install QT5 on your system manually, but we do not offer support for missing libraries on your system.
    http://qt-project.org/downloads
    Last edited by dante696; April 24th, 2014 at 12:40 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    February 2011
    Location
    Russia
    Posts
    23
    Thx for all.
    Just install:
    apt-get install libx11-xcb1

  7. #7
    Join Date
    May 2014
    Posts
    1

    Could not load or find "xcb"

    Whenever i try to start teamspeak 3 client on CentOS 6, 32bit i get this error:

    Code:
    This application failed to start because it could not find or load the Qt platform plugin "xcb".

    Also i get this when i run the command: ldd platforms/libqxcb.so

    Code:
        linux-gate.so.1 =>  (0xb7768000)
            libdl.so.2 => /lib/libdl.so.2 (0xb7672000)
            libX11.so.6 => not found
            libX11-xcb.so.1 => not found
            libSM.so.6 => not found
            libICE.so.6 => not found
            libxcb.so.1 => not found
            libfontconfig.so.1 => not found
            libfreetype.so.6 => not found
            libQt5Gui.so.5 => ./libQt5Gui.so.5 (0xb72aa000)
            libQt5Core.so.5 => ./libQt5Core.so.5 (0xb6d85000)
            libpthread.so.0 => /lib/libpthread.so.0 (0xb6d6a000)
            libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6c7f000)
            libm.so.6 => /lib/libm.so.6 (0xb6c55000)
            libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb6c36000)
            libc.so.6 => /lib/libc.so.6 (0xb6aa0000)
            /lib/ld-linux.so.2 (0xb7769000)
            libz.so.1 => /lib/libz.so.1 (0xb6a8c000)
            librt.so.1 => /lib/librt.so.1 (0xb6a83000)

  8. #8
    Join Date
    May 2014
    Posts
    1
    Same issue here on Archlinux-amd64:

    Code:
    $ teamspeak3 
    This application failed to start because it could not find or load the Qt platform plugin "xcb".
    
    Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.
    
    Reinstalling the application may fix this problem.
    ./ts3client_runscript.sh: line 15:  8693 Aborted                 (core dumped) ./ts3client_linux_amd64 [email protected]
    EDIT:

    Downgrading to teamspeak3-3.0.13.1 worked for me, at least as a workaround.
    I got the Arch package here, if you can't find the binaries (you'll have to manually extract this if you're a non-arch user)
    Last edited by hobarrera; May 26th, 2014 at 04:29 PM.

  9. #9
    Join Date
    May 2014
    Posts
    4
    I also just started having this problem on Arch. It started yesterday, which is odd because no TeamSpeak package updates have occurred since March. Maybe it's a Qt update? I don't know. Version 3.0.13-1 doesn't open links when they are clicked. Both myself and a friend are having this issue. It did not work in Firefox and it is not working in Chromium. Any idea what's causing this issue?

  10. #10
    Join Date
    March 2015
    Posts
    1

    Ubuntu 14.04 LTS, TS3.0.16 fails to run, qt 'xcb' plugin not found

    I have a fresh Ubuntu Desktop install, 14.04 LTS. I ran the TS3 installer which I d/led off the Teamspeak homepage today. The installer runs without error.

    When trying to run the TeamSpeak client, I get the following error:

    This application failed to start because it could not find or load the Qt platform plugin "xcb".

    Available platform plugins are: xcb.

    Reinstalling the application may fix this problem.
    ./ts3client_runscript.sh: line 17: 4003 Aborted (core dumped) ./ts3client_linux_x86 [email protected]


    I haven't installed any QT or QT plugins; that seems to come installed already with Ubuntu. A quick google of the issue hasn't turned up anything concrete, only a recommendation that binary needs to be re-linked (which obviously I cannot alter for Teamspeak), or a suggestion to rebuild qt (which I don't want to do by hand until I'm sure it will solve this).

    Any advice?

  11. #11
    Join Date
    October 2015
    Location
    Italy, Piedmont
    Posts
    1

    Can't open ts3 on Lubuntu

    Hello! I just installed TS3 (3.0.18.1) on Lubuntu (14.04.3 x64).
    But, if i try to start TeamSpeak, the console report the following error:
    Code:
    This application failed to start because it could not find or load the Qt platform plugin "xcb".
    
    Available platform plugins are: xcb.
    
    Reinstalling the application may fix this problem.
    Aborted (core dumped)
    I tried to do: sudo apt-get install xcb, fix permission, reboot but nothing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 10:39 AM
  2. [Resolved] TS3 Overlay + "Platform Update For Windows 7" (KB2670838) Crashing Star Trek Online
    By GT500 in forum Client Plugins / Lua Scripts
    Replies: 4
    Last Post: March 14th, 2013, 09:56 AM
  3. Please Update this Plugin ""Connection History"" Or Include to Client Version
    By varela1george in forum Suggestions and Feedback
    Replies: 2
    Last Post: October 13th, 2012, 07:28 AM
  4. Can I use "whisper" to enable a "Public" and "Private" channel?
    By DadisAjax in forum General Questions
    Replies: 2
    Last Post: June 28th, 2012, 11:59 PM
  5. Replies: 15
    Last Post: June 20th, 2012, 12:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •