Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 26
  1. #1
    Join Date
    April 2014
    Posts
    1

    Linux: Keyboard doesn't respond since 3.0.14

    Hello. First of all sorry for my english.
    Yesterday I Installed Puppy Linux and Team Speak 3 it works! But I can't write anything on chat or change nickname only works when I copy from text editor and paste by pressing mouse "Paste and send". I don't know why Push to talk works (I use "1" for talking) I tried fix this problem and searched about option "Mouse and keyboard only" in Options>Hotkeys (right bottom corner) but I haven't this option. My TeamSpeak version is 3.0.14. I'll be very happy if someone had similar problem and fixed it.

  2. #2
    Join Date
    April 2014
    Posts
    5

    Arrow

    same problem on ubuntu 14.04 64bit, downloaded TeamSpeak3-Client-linux_amd64-3.0.14.run and install it, after that keyboard not workin on TS3 client here ist terminal :

    Code:
    ./ts3client_runscript.sh 
    Error:    Could not resolve keysym ISO_Level2_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Shift; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Shift; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Lock; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Lock; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Group_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Next_Group; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Prev_Group; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_First_Group; Symbol interpretation ignored
    Error:    Abandoning compatibility map "default"
    Error:    Abandoning compatibility map "complete"
    Error:    Abandoning compatibility map "(unnamed)"
    Error:    Failed to compile xkb_compatibility
    Error:    Failed to compile keymap
    Qt: Failed to compile a keymap
    2014-04-26 21:15:08.581815|INFO    |              |   | TeamSpeak 3 Client 3.0.14 (2014-03-12 11:49:03)
    2014-04-26 21:15:08.582000|INFO    |              |   | SystemInformation: Linux 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 Binary: 64bit
    2014-04-26 21:15:08.582077|INFO    |              |   | Using hardware aes
    2014-04-26 21:15:08.611914|DEBUG   |PulseAudio    |   | connected to pulse audio server
    2014-04-26 21:15:08.622779|INFO    |ZipArchive    |   | zip open: /home/plazma/İndirilenler/TeamSpeak3-Client-linux_amd64/gfx/ error: -1000
    QuaZip::getCurrentFileName(): ZIP is not open in mdUnzip mode
    2014-04-26 21:15:08.626417|INFO    |ZipArchive    |   | zip open  reading settings.ini error: -1000
    2014-04-26 21:15:08.626576|INFO    |              |   | Loading plugin: libappscanner_plugin
    2014-04-26 21:15:08.626603|INFO    |              |   | Loading plugin: libclientquery_plugin
    2014-04-26 21:15:08.626622|INFO    |              |   | Loading plugin: liblua_plugin
    2014-04-26 21:15:08.626640|INFO    |              |   | Loading plugin: libtest_plugin
    2014-04-26 21:15:08.627638|INFO    |Query         |   | listening on 127.0.0.1:25639
    2014-04-26 21:15:08.897278|INFO    |              |   | *** Time [MAINWINDOW_ACTIONS]: 122
    2014-04-26 21:15:09.164731|INFO    |              |   | *** Time [SERVERVIEW_ACTIONS]: 129
    2014-04-26 21:15:09.165503|INFO    |              |   | *** Time [SERVERVIEW]: 137
    ClientQueryPlugin: currentServerConnectionChanged 1 (0)
    2014-04-26 21:15:09.171938|INFO    |              |   | *** Time [SERVERVIEWMANAGER]: 163
    2014-04-26 21:15:10.389196|INFO    |              |   | *** Time [MAINWINDOW]: 403
    2014-04-26 21:15:10.389426|INFO    |              |   | *** Time [INIT]: 403
    2014-04-26 21:15:10.389488|INFO    |ClientUI      |   | *** Time [SQLITE_CONVERTER]: 3
    2014-04-26 21:15:10.392886|INFO    |ClientUI      |   | Failed to init text to speech engine
    2014-04-26 21:15:10.392943|INFO    |ClientUI      |   | Qt version: 5.2.1
    2014-04-26 21:15:10.392966|INFO    |ClientUI      |   | Using configuration location: /home/plazma/.ts3client/settings.db
    2014-04-26 21:15:10.890500|INFO    |ClientUI      |   | Last update check was: 
    Unknown property align
    Unknown property align
    Unknown property align
    Unknown property align
    how can i fix this ?

  3. #3
    Join Date
    April 2014
    Posts
    5
    and support r u there or nearly one month past ll be wait another one ?

  4. #4
    Join Date
    September 2012
    Posts
    6,080
    You didn't give any information whatsoever. Like what keyboard you use, possible settings you made, any keyboard software you may have installed, keyboard layout, location settings etc. You also didn't post any kind of log.
    plazma did post his log, however from the log it seems the client was not installed properly, not to mention he too didn't specify the keyboard or location settings, keyboard layout etc.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  5. #5
    Join Date
    April 2014
    Posts
    5

    Question

    Quote Originally Posted by Chris View Post
    You didn't give any information whatsoever. Like what keyboard you use, possible settings you made, any keyboard software you may have installed, keyboard layout, location settings etc. You also didn't post any kind of log.
    plazma did post his log, however from the log it seems the client was not installed properly, not to mention he too didn't specify the keyboard or location settings, keyboard layout etc.
    There is no keyboard settings or software, using Turkish Q Keybord, another app or software keyboards working normal. Which logs do you want/need ?


    Linux Mint 17 64 bit :


    Code:
    ./ts3client_runscript.sh 
    Error:    Could not resolve keysym ISO_Level2_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Shift; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Shift; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Lock; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Level3_Lock; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Group_Latch; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Next_Group; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_Prev_Group; Symbol interpretation ignored
    Error:    Could not resolve keysym ISO_First_Group; Symbol interpretation ignored
    Error:    Abandoning compatibility map "default"
    Error:    Abandoning compatibility map "complete"
    Error:    Abandoning compatibility map "(unnamed)"
    Error:    Failed to compile xkb_compatibility
    Error:    Failed to compile keymap
    Qt: Failed to compile a keymap
    2014-07-04 21:15:23.998949|INFO    |              |   | TeamSpeak 3 Client 3.0.14 (2014-03-12 11:49:03)
    2014-07-04 21:15:23.999112|INFO    |              |   | SystemInformation: Linux 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 Binary: 64bit
    2014-07-04 21:15:23.999172|INFO    |              |   | Using hardware aes
    2014-07-04 21:15:24.013590|DEBUG   |PulseAudio    |   | connected to pulse audio server
    2014-07-04 21:15:24.024192|INFO    |ZipArchive    |   | zip open: /home/plazma/İndirilenler/TeamSpeak3-Client-linux_amd64/gfx/ error: -1000
    QuaZip::getCurrentFileName(): ZIP is not open in mdUnzip mode
    2014-07-04 21:15:24.029453|INFO    |ZipArchive    |   | zip open  reading settings.ini error: -1000
    2014-07-04 21:15:24.029808|INFO    |              |   | Loading plugin: libappscanner_plugin
    2014-07-04 21:15:24.029877|INFO    |              |   | Loading plugin: libclientquery_plugin
    2014-07-04 21:15:24.029928|INFO    |              |   | Loading plugin: liblua_plugin
    2014-07-04 21:15:24.029975|INFO    |              |   | Loading plugin: libtest_plugin
    2014-07-04 21:15:24.032480|INFO    |Query         |   | listening on 127.0.0.1:25639
    2014-07-04 21:15:24.258587|INFO    |              |   | *** Time [MAINWINDOW_ACTIONS]: 121
    2014-07-04 21:15:24.531356|INFO    |              |   | *** Time [SERVERVIEW_ACTIONS]: 132
    2014-07-04 21:15:24.532281|INFO    |              |   | *** Time [SERVERVIEW]: 144
    ClientQueryPlugin: currentServerConnectionChanged 1 (0)
    2014-07-04 21:15:24.538796|INFO    |              |   | *** Time [SERVERVIEWMANAGER]: 165
    2014-07-04 21:15:25.806257|INFO    |              |   | *** Time [MAINWINDOW]: 417
    2014-07-04 21:15:25.806448|INFO    |              |   | *** Time [INIT]: 417
    2014-07-04 21:15:25.806499|INFO    |ClientUI      |   | *** Time [SQLITE_CONVERTER]: 2
    2014-07-04 21:15:25.810288|INFO    |ClientUI      |   | Failed to init text to speech engine
    2014-07-04 21:15:25.810396|INFO    |ClientUI      |   | Qt version: 5.2.1
    2014-07-04 21:15:25.810446|INFO    |ClientUI      |   | Using configuration location: /home/plazma/.ts3client/settings.db
    2014-07-04 21:15:26.307464|INFO    |ClientUI      |   | Last update check was: 
    Unknown property align
    Unknown property align
    Unknown property align
    Unknown property align

    "Qt: Failed to compile a keymap" i thing its the problem.

    diffrent new distro installed yesterday.

  6. #6
    Join Date
    December 2012
    Location
    Bavaria, DE
    Posts
    120

    Keyboard didnt accepted

    Error: Couldn't find file "rules/" in include paths
    Error: 2 include paths searched:
    Error: /usr/share/X11/xkb
    Error: /home/ts3client/.xkb
    Error: Couldn't look up rules '', model 'pc105', layout '@', variant '', options ''
    Qt: Failed to compile a keymap

    its on a root system
    Last edited by dante696; July 15th, 2014 at 02:18 PM. Reason: merged

  7. #7
    Join Date
    June 2008
    Posts
    18,409
    It seems you miss a system library to handle your keyboard. We do not deliver such libraries.

    You also miss details about operation system and hardware and installed libraries.
    Last edited by dante696; July 7th, 2014 at 04:23 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    May 2012
    Location
    The 3rd dimension
    Posts
    956
    I am having the same problem. I just upgraded my VPS server's TeamSpeak 3 client (x86) on ubuntu server and now I am unable to type anything in TeamSpeak client. I connect via VNC. I never used to have a problem until I updated. I think I was on .13.1 or something before. Now TeamSpeak client is useless and I do not have the old version to put back on...

    Edit

    I even tried to sudo run it with full privileges on ubuntu and still I am completely unable to type into anything on TeamSpeak. I even rebooted my server (something I never do) because I thought it was my server for some reason and still nothing. Everything else works and I can type in any other screen except anything to do with the new upgraded TeamSpeak client.

  9. #9
    Join Date
    December 2012
    Location
    Bavaria, DE
    Posts
    120
    OS: Linux ( Debian-75-wheezy-64-minimal)
    ldd: cant do that because the file are not available
    Ram:47 GB

  10. #10
    Join Date
    August 2013
    Location
    Alfeld (Leine), Germany
    Posts
    7
    I can reproduce this issue too on my Ubuntu 13.10 machine with OpenBox.

    The problem exists since the QT5 update. The QT4 versions work fine (3.0.13.1)..

  11. #11
    Join Date
    May 2012
    Location
    The 3rd dimension
    Posts
    956

    Unable to type on the latest client on linux (ubuntu).

    Nothing I do will let me type on the client. This happened a couple or so updates ago. At the time the version I was using worked flawlessly and when I upgraded I no longer could type, yet the older one worked fine. I upgraded today hoping that was resolved and still the issue exists. There is nothing you can type into TeamSpeak. Not a name, not an address, not a message. Nothing.

  12. #12
    Join Date
    June 2013
    Location
    TeamSpeak Community Forums
    Posts
    108

    Reply

    Just to second this, the latest client doesn't work on Debian 7 Wheezy x64 either.

  13. #13
    Join Date
    June 2008
    Posts
    18,409
    Logs logs logs logs, that is what we need from you.

    It works fine for us on Ubuntu and Debian. Tested in a VM and real machine.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  14. #14
    Join Date
    May 2012
    Location
    The 3rd dimension
    Posts
    956
    Code:
    8/22/14 17:34:49        Info    TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)    
    8/22/14 17:34:49        Info    SystemInformation: Linux 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:36:13 UTC 2013 i686 Binary: 32bit    
    8/22/14 17:34:49    SoundBckndIntf    Error    libpulse.so.0: cannot open shared object file: No such file or directory    
    8/22/14 17:34:49        Info    Loading plugin: libappscanner_plugin    
    8/22/14 17:34:49        Info    Loading plugin: libclientquery_plugin    
    8/22/14 17:34:49        Info    Loading plugin: liblua_plugin    
    8/22/14 17:34:49        Info    Loading plugin: libtest_plugin    
    8/22/14 17:34:49    Query    Info    listening on 127.0.0.1:25639    
    8/22/14 17:34:49        Info    *** Time [MAINWINDOW]: 119    
    8/22/14 17:34:49        Info    *** Time [INIT]: 119    
    8/22/14 17:34:49    ClientUI    Info    Failed to init text to speech engine    
    8/22/14 17:34:49    ClientUI    Info    Qt version: 5.2.1    
    8/22/14 17:34:49    ClientUI    Info    Using configuration location: /home/username/.ts3client/settings.db    
    8/22/14 17:34:50    ClientUI    Info    Last update check was: Thu Aug 21 19:43:20 2014    
    8/22/14 17:34:50        Info    Checking for updates...    
    8/22/14 17:34:50    TSDNS    Info    DNS resolve successful, "update.teamspeak.com"=176.9.148.78    
    8/22/14 17:34:55        Info    Update check timeout
    I am using the latest stable client on Ubuntu server VPS using LXDE interface and connecting via VNC. I never had a problem until 2 or 3 versions or so ago. I know it is a client issue because at the time I could use the one I had at the time and the newer one would not type.

  15. #15
    Join Date
    August 2014
    Posts
    1
    sudo vi /usr/share/X11/xkb/rules/xorg

    find a line like this: (mine was around line 25 on puppy linux)

    btc5113rf btc5126t btc9000 btc9000a btc9001ah btc5090\

    solution add a space before the backslash to match the rest of the file

    btc5113rf btc5126t btc9000 btc9000a btc9001ah btc5090 \

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How can I make TS3 respond to my laptop keyboard?
    By Aegisthus in forum General Questions
    Replies: 0
    Last Post: January 19th, 2014, 11:54 PM
  2. TS doesn't respond properly with mouse
    By johnenglish in forum Windows
    Replies: 0
    Last Post: March 19th, 2013, 02:33 PM
  3. TS3 doesn't respond to mouse/keyboard
    By Fast Forward in forum Client Support
    Replies: 2
    Last Post: January 14th, 2010, 05:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •