Forum

Results 1 to 2 of 2
  1. #1
    Join Date
    March 2012
    Location
    Gothenburg, Sweden
    Posts
    54

    [ServerQuery Bug] Unintentional character escape in a forward-slash?

    Hi guys.

    After extensive testing using serverquery in a new application to work with my server, I have found that forward-slashes are escaped. In my case, I found a forward-slash escaped in a user's unique id.

    Code:
    sR\/12P6fJAJngNXQqK+JM
    That backslash is not supposed to be there. Correct output is:

    Code:
    sR/12P6fJAJngNXQqK+JM
    Forward-slashes are not escaped in many languages that I am familiar with, so this had me concerned for future issues regarding characters that are normally not escaped (specifically C#.NET in my case).

    Would be thankful for your input on this, and if there is anything else I should be worried about except the forward-slashes.

  2. #2
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,510
    This is not a bug. Check out page 5 of the ServerQuery documentation for a list of escaped characters:

    http://media.teamspeak.com/ts3_liter...y%20Manual.pdf

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Suggestion: Allow complaining against a user who disconnects to escape.
    By Morthawt in forum Suggestions and Feedback
    Replies: 2
    Last Post: July 18th, 2014, 05:25 PM
  2. [Resolved] Slash in profile name (RC3)
    By ~Neil~ in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: June 20th, 2011, 08:28 AM
  3. Replies: 1
    Last Post: April 27th, 2010, 07:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •