Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360

    Server Query: Channel events of a single channel stops after some time

    If you do
    servernotifyregister event=channel id=123
    to receive channel events of a single channel (in this example channel id 123), it works for some hours like expected. After a day I noticed that the TS3 server is sending no channel events of the channel anymore. The channel was not deleted.

    I think this is not a wanted behavior? Using channel id=0 is working without problems.

  2. #2
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    I just tested and started subscribing at 19:35. It stopped at 23:18. So not yet 4 hours.

  3. #3
    Join Date
    June 2008
    Posts
    18,513
    We will retest that in the next days.
    Was there a lot action on your server?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    Quote Originally Posted by dante696 View Post
    We will retest that in the next days.
    Was there a lot action on your server?
    Was a bigger server, but there was only around 10 channel events for the one channel in the first 8 hours. Later I realized that no channel event will be triggered on telnet, if someone join that channel.

  5. #5
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    I subscribed to a guild's default channel right before GW2 guild missions. I'd guess like 200 people entered the server and left the channel in that timeframe.

  6. #6
    Join Date
    June 2008
    Posts
    18,513
    How do you keep the connection alive to telnet/putty/ your tool?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    Quote Originally Posted by dante696 View Post
    How do you keep the connection alive to telnet/putty/ your tool?
    In my case was it my bot. All other stuff was still working (including server and chat events, just channel events was not send to my bot after around 10 hours). Sometimes the problem occur already after 4 hours, sometimes after more than 12 hours. A special debug version wrote all communication between bot and TS3 server to a file, that's why I know about this problem. After a reconnect even the channel event is working again for some hours.

  8. #8
    Join Date
    June 2008
    Posts
    18,513
    Ok, thank you for the feedback.
    Maybe we can reproduce it with a normal telnet connection.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #9
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    YaTQA sends #10#13 (I was unable to find out why TS uses this) every five minutes.

  10. #10
    Join Date
    June 2008
    Posts
    18,513
    I guess you send it, to stay connected to th Query. You connection would be closed if nothing was send to the server.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #11
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    Yes, I'm just wondering why \n\r is used instead of \n (Linux), \r (Mac) oder \r\n (Windows, most protocol standards). I couldn't find it in the standards.

  12. #12
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    @ dante696: Where you able to reproduce this bug?

  13. #13
    Join Date
    June 2008
    Posts
    18,513
    Nope not yet.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  14. #14
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    Can I help somehow?

  15. #15
    Join Date
    June 2008
    Posts
    18,513
    We could reproduce this once. But don't know why and when it happens.

    The ticket is now set as "low priority".
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Not possible] Hide a Channel or groups from users
    By Ishban in forum Permission System
    Replies: 21
    Last Post: February 1st, 2019, 08:05 AM
  2. [Not possible] Server Query Group Events
    By CalibeR.50 in forum Server Support
    Replies: 2
    Last Post: October 30th, 2015, 02:53 PM
  3. Mic stops working when I enter a server/channel
    By Impactus in forum General Questions
    Replies: 1
    Last Post: May 21st, 2013, 02:32 PM
  4. Replies: 2
    Last Post: October 13th, 2012, 11:07 AM
  5. Restricting a Channel Group to a Single Channel.
    By Dygear in forum Suggestions and Feedback
    Replies: 0
    Last Post: January 27th, 2012, 07:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •