Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    April 2014
    Posts
    4

    Client immediately crashes upon launching

    So I've been using TS3 since last December. During March I saw that there was an update but didn't click it out of fear that it would cause issues. Turns out I was right. The other day I hit enter out of habit when seeing a confirmation window and the client updated itself. It then immediately crashed and when I would click on it again it would bounce once in the dock and then the crash window would come up. I tried completely reinstalling after clearing it from every folder (including the library) but it still crashes instantly. Here is what the crash report says.


    Process: ts3client_mac [2317]
    Path: /Applications/TeamSpeak 3 Client.app/Contents/MacOS/ts3client_mac
    Identifier: com.teamspeak.TeamSpeak3
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [146]

    Interval Since Last Report: 8998 sec
    Crashes Since Last Report: 2
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 1

    Date/Time: 2014-04-29 15:03:26.110 -0500
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: 667FE089-3F0E-4183-B424-D31DBBA91C24

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    unknown required load command 0x80000022


    Looking things up I have the suspicion that this last update made the client incompatible with 10.5.8. If not I would love to know what to do to fix this issue.

  2. #2
    Join Date
    June 2008
    Posts
    18,409
    Please try client 3.0.13.1 for testing.
    http://dl.4players.de/ts/releases/3.0.13.1/
    Last edited by dante696; April 30th, 2014 at 02:53 PM. Reason: Edit
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    April 2014
    Posts
    4
    Client is downloading. Currently at uni and have a slow connection. More than likely I will go home and download if it isn't done. Will have results posted in less than an hour. Prior to download I cleared all TS3 related files from HD and UserLibrary application support.

  4. #4
    Join Date
    June 2008
    Posts
    18,409
    No problem it's 10:30 pm here.
    Need to sleep for work tomorrow

    BTW you could also check, if your CPU does support SSE2.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    April 2014
    Posts
    4
    CPU does support SSE2.

    Model Name: MacBook Pro
    Model Identifier: MacBookPro4,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.4 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 3 MB
    Memory: 2 GB
    Bus Speed: 800 MHz
    Boot ROM Version: MBP41.00C1.B03
    SMC Version (system): 1.27f3
    Serial Number (system): W8824DQHYJX
    Hardware UUID: EC5886E0-39A3-5B70-8AC2-6DA3C60786F6
    Sudden Motion Sensor:
    State: Enabled

    Will hope for the best with TS3. When I downloaded it mid december I did have to download an update at the time. If that update isn't in the download link you gave then I might not be able to connect to a server. Either way, the link you sent should allow me to at least open up the program.

  6. #6
    Join Date
    April 2014
    Posts
    4
    It worked!! Prompted an update to 3.0.14 but i opted out of that. Was able to connect and I'm now chatting with friends. If you need anything else from me to figure out whats wrong with the newest update I will check this thread.

  7. #7
    Join Date
    June 2008
    Posts
    18,409
    Quote Originally Posted by FFXIV_Mac View Post
    It worked!! Prompted an update to 3.0.14 but i opted out of that. Was able to connect and I'm now chatting with friends. If you need anything else from me to figure out whats wrong with the newest update I will check this thread.
    And it's still crashing, when you update back to 3.0.14 with an installer?
    http://dl.4players.de/ts/releases/3.0.14/

    Please deactivate all your client plugins first, to make sure nothing comes from here.
    Last edited by dante696; April 30th, 2014 at 02:52 PM. Reason: Edit
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: July 24th, 2012, 12:59 AM
  2. [Resolved] Launching TS3 while another TS3 is launching CRASHES the program
    By copper in forum Bug Reports [EN/DE]
    Replies: 3
    Last Post: January 19th, 2011, 02:01 AM
  3. Teamspeak crashes immediately on opening
    By Seragyn in forum macOS
    Replies: 2
    Last Post: August 13th, 2010, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •