I run a teamspeak server with just 32 slots max. for about a year it has ran with no problem what so ever but after i moved it started losing connection about every few hours or so.


Code:
2014-05-10 11:49:50.765603|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.10.2 (2013-12-02 08:19:01)
2014-05-10 11:49:50.765783|INFO    |ServerLibPriv |   | SystemInformation: Linux 3.6.9-030609-generic #201212031610 SMP Mon Dec 3 21:11:48 UTC 2012 x86_64 Binary: 64bit
2014-05-10 11:49:50.791743|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
2014-05-10 11:49:50.791820|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3
2014-05-10 11:49:50.793477|INFO    |DatabaseQuery |   | checking database integrity (may take a while)
2014-05-10 11:49:50.886825|WARNING |Accounting    |   | Unable to find valid license key, falling back to limited functionality
2014-05-10 11:49:51.564278|INFO    |              |   | Puzzle precompute time: 669
2014-05-10 11:49:51.564915|INFO    |FileManager   |   | listening on 0.0.0.0:30033
2014-05-10 11:49:51.688796|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
2014-05-10 11:49:51.689829|INFO    |Query         |   | listening on 0.0.0.0:10011
2014-05-10 17:34:52.725633|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
2014-05-10 17:34:52.725727|DEVELOP |              |   | UDPConnection::send failed to update target ip
2014-05-10 17:34:52.725743|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:34:52.725756|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:34:54.027810|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:34:54.027862|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:34:56.030977|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:34:56.031036|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:44:52.734777|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:44:52.734844|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:44:54.061093|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
2014-05-10 17:44:54.061141|DEVELOP |              |   | UDPConnection::send failed to update target ip
2014-05-10 17:44:54.061158|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:44:54.061171|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:44:56.064133|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:44:56.064190|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:54:52.786044|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:54:52.786097|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:54:54.087764|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:54:54.087814|ERROR   |              |   | TS3ANetwork::Send failed error: 22
2014-05-10 17:54:56.114318|ERROR   |              |   | TS3ANetwork::Connect failed error: 22
2014-05-10 17:54:56.114364|DEVELOP |              |   | UDPConnection::send failed to update target ip
i run a linksys E1500 router and i believe it may be the problem but i'm unsure. If anyone has any idea whats going on or what i could do next to assess the situation that would be awesome. Thanks for taking the time to read this.
Rebooting router and restarting teamspeak server resolves the issue temporarily.