Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    May 2014
    Posts
    3

    Voice lag in game

    I'm having an issue with TS when my games are minimized my microphone quality is fine and as soon as I maximize the game my voice is instantly laggy. Now this issue doesnt always happen it will be fine for a few hours then out of no where the quality starts acting up. As soon as I minimize it works fine again until I bring a game back up.

    My broadband connection is 120mb/s down and 12mb/s up.

    My pc specs are

    2 gtx 780s sli
    3570k 3.8Ghz
    16gb DDR3
    Creative Z sound card
    astro mix amp + Siberia V2 Headset
    windows 7 ultimate

  2. #2
    Join Date
    September 2013
    Location
    Croatia
    Posts
    93
    Maybe its a problem with the game itself? Check game audio settings...

  3. #3
    Join Date
    May 2014
    Posts
    3
    It used to happen with BF3, BF4 and now its started happening on Arma 2. No idea whats causing it. I doubt it would be anything to do with game settings if its happening on multiple games

  4. #4
    Join Date
    May 2014
    Posts
    3
    bump, anyone have any ideas??? Its getting worse now seems to be happening all the time, I've tried doing a complete install of TS3, driver sweeped all my sound drivers and resinstalled still no luck?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •