Forum

Results 1 to 10 of 10
  1. #1
    Join Date
    June 2014
    Posts
    8

    Can't set permissions in ServerAdmin group...

    Hi,

    I'm a (relatively new) TS3 ServerAdmin.
    When I setup the TS3 server everything was fine.
    Now I want to change / add new permissions in the Server Admin Group - but I can't!
    I want to set:
    b_virtualserver_modify_temporary_passwords
    b_virtualserver_modify_temporary_passwords_own

    But I always get the message:
    insufficient permission modify power

    Name:  permission.jpg
Views: 2092
Size:  25.0 KB

    What happened?
    The "First Aid Guide" doesn't work for me, because I couldn't find the permid for those permissions.

    TS-Server (Debian x64): 3.0.10.3
    TS-Client (Windows 7 x64): 3.0.14

    Hope for help...

    Irontiger

    PS: When I noticed that problem I tried to add other (not yet set permissions) and they don't work as well...

  2. #2
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,342
    You cannot add permissions you don't have (of course!). Ask your TS3 provider.

  3. #3
    Join Date
    June 2014
    Posts
    8
    Thanks for your fast answer!

    Well, it's my server, so there is no provider. Do I need a licence for that permission?

    Greetings

    Irontiger

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,342
    No. If you don't have all permissions you need, you can get them by using server query to assign them to your Server Admin group. It either works by command line interface or with GUIs like YaTQA.

  5. #5
    Join Date
    May 2012
    Location
    The 3rd dimension
    Posts
    956
    There are two ways I can think of that may have caused this. Either your server has been around for a long time and has been updated through many versions and the update where temporary server passwords were introduced had some kind of error during database upgrade, or a top level server admin has removed the grant values manually from the permissions on the particular server groups you are looking at.

  6. #6
    Join Date
    June 2014
    Posts
    8
    Hi

    Thanks for your answers.
    @numma_cway: I couldn't find a way to assign the missing permissions through ServerQuery, because I couldn't find the corresponding permids. YaTQA sound great, but there is no wine currently installed on the server, so I can't use it. Can you help me with the ServerQuery?
    @Morthawt: The server is using mysqlLite - that's why it shouldn't happen because of a mySQL update. But you are right: the server was installed as a RC (first RC of TS3 server) and upgraded many times.
    @all: There is something else I remember. We transfered the server, meaning:
    I exported the permissions via ServerQuery and imported them into the new TS3 server (the version from first post). Could this be the reason for my problem?
    In general: I'm confused about the permissions system. I would expect that the server admin group always get all permissions on the server - even new ones after an update... weird...

    Greetings

    Irontiger

  7. #7
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,342
    YaTQA must not be installed on a server. It's a client software. Only a few people actually mananged to do make it run on Windows 2008 R2.

  8. #8
    Join Date
    June 2014
    Posts
    8
    Thanks for pointing that out, I'll try YaTQA.

  9. #9
    Join Date
    May 2012
    Location
    The 3rd dimension
    Posts
    956
    As long as you have the main serveradmin query account details you should be able to fix it, although I do not know those commands. My query knowledge is very basic because about all I need to do is bring up channelinfo.

  10. #10
    Join Date
    June 2014
    Posts
    8
    Hi,

    thanks for your help! YaTQA was a great tip, now it's working

    Greetings

    IT

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Removed my Serveradmin / Lost my Identity
    By Hazyoner in forum Permission System
    Replies: 2
    Last Post: December 23rd, 2015, 02:25 AM
  2. serveradmin no permissions
    By slushpuppy in forum Permission System
    Replies: 1
    Last Post: July 7th, 2014, 09:49 AM
  3. serveradmin group revoked
    By Niklons in forum Server Support
    Replies: 4
    Last Post: June 28th, 2013, 10:12 AM
  4. Modify Serveradmin Group
    By ernestoo in forum Server Support
    Replies: 14
    Last Post: January 3rd, 2011, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •