Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    June 2014
    Posts
    1

    Unable to update server

    Hello,

    I'm having trouble updating my ts3 on my Debian server. It's currently in 3.0.10 and I'm trying to upgrade it to 3.0.10.3 (server amd64). I had followed all steps from the MySQL topic of these forums to get it to work when I was installing the server.

    I tried updating it months ago, by simply replacing ts3server_linux_amd64, but as it didn't work, I didn't want to let the server offline for too long. So I tried again last night, after backing up both folders and the DB, but after a failed attempt with file replacement, I tried on a fresh install, following the steps described in the MySQL topic. That's where it becomes strange, it did not work on a fresh install but it did work after I replaced, in the new ts folder, the ts3server_linux_amd64 with the OLDER one.

    I'm not expert but it seems like a problem with the program itself? I didn't find anything wrong in the changelog, like a new var or anything defined...

    I can send logs if you want, but they're exactly the same as if the server started right! I checked ports and all, but I'm still getting a Failed to connect with that executable and not the other...

    Thanks in advance for help!

  2. #2
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    Hello,

    my script may can help you to update your server. It also checks your server state after updating process. Well... If the server can't start up, the script will rollback to the old running TeamSpeak server version, which was backed up by the script automatic.

    Further information can be found on the addons page: http://addons.teamspeak.com/director...n-checker.html

    Oh... Please use the latest version. I'm not able to upload the latest version to addons.teamspeak.com since I think 6 months, because TeamSpeak Systems is renewing the page. You can find the latest version here: http://files.ts3-tools.info/TS3_UpdateScript/3/

    I think, you have just done something wrong while updating and that's maybe the issue.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to Update
    By iflog in forum Windows
    Replies: 7
    Last Post: April 1st, 2017, 04:49 PM
  2. [Resolved] Unable to update client to 3.0.16 - Unable to download new client
    By TheRealJaycen in forum Windows
    Replies: 4
    Last Post: April 5th, 2015, 02:30 AM
  3. [Resolved] unable to update
    By gladiss in forum Linux
    Replies: 2
    Last Post: August 27th, 2013, 09:25 PM
  4. Windows 7 64 Bit - Unable to update
    By gibsonm in forum Windows
    Replies: 4
    Last Post: July 2nd, 2011, 05:09 AM
  5. After update to Beta18 - Unable to connect
    By <$T$>ERROR in forum Windows
    Replies: 0
    Last Post: February 20th, 2010, 05:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •